Lektion 2

Forum især for de unge linux-brugere. Det eneste sted på forum hvor SMS-forkortelser er tilladt :-)

Redaktør: Måns

Re: Lektion 2

Indlægaf Måns » søn 6. feb 2011 18:27

Birthe skrev:Der er et kendt problem med Stardust (som vist er bygget på 4.31.

Jeg forsøgte lige i Puppy 5.1
Kode: Vælg alt
mount /dev/sdg1  /mnt/sdg1


Det virkede.

Mvh. Birthe

Jeg bruger også Puppy 5.1 (Puppy Studio noRT)
Mit resultat:
Kode: Vælg alt
# mount /dev/sda1  /mnt/sda1
mount: mount point /mnt/sda1 does not exist

Min harddisk hedder sda1 - og mountes, hvis jeg klikker på desktopikonet!!
Det samme er tilfældet når jeg prøver med sdc1 (en usb) :sad:
Kode: Vælg alt
# mount /dev/sdc1  /mnt/sdc1
mount: mount point /mnt/sdc1 does not exist


Det her er altså ret mærkeligt:
Jeg mounter sdc1 vha pmount appletten og prøver at unmounte vha konsollen:
Kode: Vælg alt
# umount /dev/sdc1  /mnt/sdc1

Filvinduet bliver tomt!! men skrivebordsikonet viser at disken stadig er mounted!!!
og svaret i konsollen er:
Kode: Vælg alt
umount: can't umount /mnt/sdc1: Invalid argument

Så prøver jeg enkeltvis:
Kode: Vælg alt
# mount /dev/sdc1
mount: can't find /dev/sdc1 in /etc/fstab or /etc/mtab

og
Kode: Vælg alt
# mount /mnt/sdc1
mount: can't find /mnt/sdc1 in /etc/fstab or /etc/mtab

Konstaterer at systemet stadig tror at disken er mounted (på trods af tømt filmappe, dvs kun tilsyneladende - ikonet viser jo noget andet..) og prøver at unmounte igen:
Kode: Vælg alt
# umount /dev/sdc1  /mnt/sdc1
umount: can't umount /mnt/sdc1: Invalid argument


Hmm - der må være en anden måde at gøre det på - eller også er min 5.1'er (Studio) rippet for et-eller-andet, der gør at den opfører sig forkert ved forsøg mount og umount via konsol.. :cry:
:cheers: Måns
Quote: "Give a man a tiddler and he might digest it today, show a man how to use TIddlyWiki and he'll be writing his own tiddlers for a lifetime .."
Brugeravatar
Måns
Site Admin
Site Admin
 
Indlæg: 1763
Tilmeldt: tirs 5. jan 2010 18:32
Geografisk sted: Havbro, Aars, Himmerland, Nordjylland, Jylland, Danmark
Brugererfaring med Linux:: Øvet

Re: Lektion 2

Indlægaf Birthe » søn 6. feb 2011 18:37

Det er godt nok underligt.

Her afmonterer
Kode: Vælg alt
umount /dev/sdg1


Altså uden videre angivelse af HVOR, som når jeg beder den montere. Jeg fatter NADA.

Mvh. Birthe
Mvh. Birthe

Lenovo T500 Intel Core 2 Duo 2.53 GHz, 2 GB DDR3, 160GB 7200rpm, ATI Mobility Radeon HD 3650, Mint 17.2 Mate
Lenovo X100e 2gb ram, AMD Athlon Neo MV-40 / 1.6 GHz, ATI Mobility Radeon HD 3200, zorin 6.4 core
Acer Aspire One zg5, Intel Atom N270, 1.6 GHz, integreret grafik, 1gb ram, 160 gb hd. (Mint 17.3 Mate)
Brugeravatar
Birthe
Site Admin
Site Admin
 
Indlæg: 2529
Tilmeldt: lør 30. okt 2010 09:09
Geografisk sted: Odense, Fyn
Brugererfaring med Linux:: Lidt øvet

Re: Lektion 2

Indlægaf Birthe » søn 6. feb 2011 18:48

Altså skrivebords ikonet for drevet er der stadig, men farven i "prikken", ændres behørigt. Jeg kan også i den grafiske aplet se, at der er henholdvis monteret eller afmonteret.

Hvis jeg KUN skriver
Kode: Vælg alt
mount /dev/ sdg1

altså udelader
/mnt/sdg1

Får jeg samme fejlmelding, som du får.
Jeg skal derimod ikke have den del med, når jeg afmonterer.

Har du googlet om andre har haft problemer med Puppy Studio noRT?

Mvh. Birthe
Mvh. Birthe

Lenovo T500 Intel Core 2 Duo 2.53 GHz, 2 GB DDR3, 160GB 7200rpm, ATI Mobility Radeon HD 3650, Mint 17.2 Mate
Lenovo X100e 2gb ram, AMD Athlon Neo MV-40 / 1.6 GHz, ATI Mobility Radeon HD 3200, zorin 6.4 core
Acer Aspire One zg5, Intel Atom N270, 1.6 GHz, integreret grafik, 1gb ram, 160 gb hd. (Mint 17.3 Mate)
Brugeravatar
Birthe
Site Admin
Site Admin
 
Indlæg: 2529
Tilmeldt: lør 30. okt 2010 09:09
Geografisk sted: Odense, Fyn
Brugererfaring med Linux:: Lidt øvet

Re: Lektion 2

Indlægaf Måns » søn 6. feb 2011 19:24

Birthe skrev:Altså skrivebords ikonet for drevet er der stadig, men farven i "prikken", ændres behørigt. Jeg kan også i den grafiske aplet se, at der er henholdvis monteret eller afmonteret.
----
Har du googlet om andre har haft problemer med Puppy Studio noRT?

Mvh. Birthe

Hej Birthe "farven i prikken" :grin: ændres ikke ved umount hos mig...
Jeg har lige prøvet de samme kommandoer i MacPup - med samme "ikke-resultat":
Kode: Vælg alt
# mount /dev/sdc1  /mnt/sdc1
mount: mount point /mnt/sdc1 does not exist
# mount /dev/sda1  /mnt/sda1
mount: mount point /mnt/sda1 does not exist
# mount /dev/sdg1  /mnt/sdg1
mount: mount point /mnt/sdg1 does not exist
# mount /dev/sdb1  /mnt/sdb1
mount: mount point /mnt/sdb1 does not exist
# mount/dev/sdc1  /mnt/sdc1
bash: mount/dev/sdc1: No such file or directory
# mount /dev/sdc1 /mnt/sdc1
mount: mount point /mnt/sdc1 does not exist
# mount /dev/sdc1/mnt/sdc1
mount: can't find /dev/sdc1/mnt/sdc1 in /etc/fstab or /etc/mtab
# mount /dev/sdc1 /mnt/sdc1
mount: mount point /mnt/sdc1 does not exist
# mount /dev/sdc1
mount: can't find /dev/sdc1 in /etc/fstab or /etc/mtab
# mount /mnt/sdc1
mount: can't find /mnt/sdc1 in /etc/fstab or /etc/mtab


Jeg tror lige jeg tager en pause og laver noget helt andet - Det trænger jeg vist til :shock: :ugeek: :wink:

Mvh Måns
Quote: "Give a man a tiddler and he might digest it today, show a man how to use TIddlyWiki and he'll be writing his own tiddlers for a lifetime .."
Brugeravatar
Måns
Site Admin
Site Admin
 
Indlæg: 1763
Tilmeldt: tirs 5. jan 2010 18:32
Geografisk sted: Havbro, Aars, Himmerland, Nordjylland, Jylland, Danmark
Brugererfaring med Linux:: Øvet

Re: Lektion 2

Indlægaf Birthe » søn 6. feb 2011 19:48

Hej Måns.
Måns skrev:Jeg tror lige jeg tager en pause og laver noget helt andet - Det trænger jeg vist til :shock: :ugeek: :wink:

Ja, og kan du finde på lidt selvforkælelse, er det velundt :smile:

Det virker i Flexxpup 1.9.
Jeg har lige brændt en dvd multisession med Lupu 5.2. Jeg reboot'er lige og prøver den af.

Måske du har læst, at en del havde problemer med lyden i lupu 5.1 Jeg er en af dem. Men kun på en computer. Den har problemet i uløselig grad i Windows, hvilket så også er grunden til, jeg fik den billigt brugt :lol: :lol: :lol:
Linux plejer at virke glimrende. :thumbup:
Det er skrup ærgerligt, for jeg er meget begejstret for Flexxpup 1.9. Ved første boot er der lyd, men forholdsvist svagt. Efter reboot og savefil ikke det, der ligner lyd. Jeg har rodet med retrovol, jeg har rodet med Alsa. Jeg tror lige præcis, jeg ved, hvordan du har det med det mount/umount "sjov". :???:

Mvh. Birthe
Mvh. Birthe

Lenovo T500 Intel Core 2 Duo 2.53 GHz, 2 GB DDR3, 160GB 7200rpm, ATI Mobility Radeon HD 3650, Mint 17.2 Mate
Lenovo X100e 2gb ram, AMD Athlon Neo MV-40 / 1.6 GHz, ATI Mobility Radeon HD 3200, zorin 6.4 core
Acer Aspire One zg5, Intel Atom N270, 1.6 GHz, integreret grafik, 1gb ram, 160 gb hd. (Mint 17.3 Mate)
Brugeravatar
Birthe
Site Admin
Site Admin
 
Indlæg: 2529
Tilmeldt: lør 30. okt 2010 09:09
Geografisk sted: Odense, Fyn
Brugererfaring med Linux:: Lidt øvet

Re: Lektion 2

Indlægaf kaare » søn 6. feb 2011 20:47

Hej .. Så kunne jeg være her.. :)

Hvis du skriver

Kode: Vælg alt
sudo dmesg
eller
Kode: Vælg alt
sudo lsusb


Når du lige har indsat din usb pind får du og vide hvilket mount point du skal bruge.. [om det er sdc eller sdb osv..]

Når du kender mount point ligner det ikke der er problemer, for der er de foreslåede ting rigtige..
----
Kåre Sørensen
kaare
Site Admin
Site Admin
 
Indlæg: 65
Tilmeldt: man 18. maj 2009 19:48
Geografisk sted: Århus C
Brugererfaring med Linux:: Meget øvet

Re: Lektion 2

Indlægaf kaare » søn 6. feb 2011 21:00

argh.. har set din fejl nu :)

Når du skriver dette (eller en af de andre tilsvarende kommandoer du laver):
Kode: Vælg alt
# mount /dev/sdc1  /mnt/sdc1
mount: mount point /mnt/sdc1 does not exist

Betyder det at "/mnt/sdc1 does not exist" .. Dette er fordi at når man mounter et "device" skal det mountes til en mappe og denne mappe skal man selv oprette. Dermed er grunden til at "/mnt/sdc1 does not exist", fordi at du endnu ikke selv har oprettet mappen med fx:
Kode: Vælg alt
sudo mkdir /mnt/sdc1

Efter dette vil det nu være muligt at mounte mount point "sdc1" med
Kode: Vælg alt
# sudo mount /dev/sdc1  /mnt/sdc1


Men igen, for at finde det rigtige mount point anbefaler jeg at du bruger "dmesg" eller "lsusb" lige efter du har indsat usb stikket..
----
Kåre Sørensen
kaare
Site Admin
Site Admin
 
Indlæg: 65
Tilmeldt: man 18. maj 2009 19:48
Geografisk sted: Århus C
Brugererfaring med Linux:: Meget øvet

Re: Lektion 2

Indlægaf Birthe » søn 6. feb 2011 21:07

kaare skrev:Betyder det at "/mnt/sdc1 does not exist" .. Dette er fordi at når man mounter et "device" skal det mountes til en mappe og denne mappe skal man selv oprette. Dermed er grunden til at "/mnt/sdc1 does not exist", fordi at du endnu ikke selv har oprettet mappen med fx:

Kode: Vælg alt
sudo mkdir /mnt/sdc1


Efter dette vil det nu være muligt at mounte mount point "sdc1" me

Det lyder logisk. Jeg undrer mig blot over, at jeg kunne mounte uden at oprette nogen mappe.

Mvh. Birthe
Mvh. Birthe

Lenovo T500 Intel Core 2 Duo 2.53 GHz, 2 GB DDR3, 160GB 7200rpm, ATI Mobility Radeon HD 3650, Mint 17.2 Mate
Lenovo X100e 2gb ram, AMD Athlon Neo MV-40 / 1.6 GHz, ATI Mobility Radeon HD 3200, zorin 6.4 core
Acer Aspire One zg5, Intel Atom N270, 1.6 GHz, integreret grafik, 1gb ram, 160 gb hd. (Mint 17.3 Mate)
Brugeravatar
Birthe
Site Admin
Site Admin
 
Indlæg: 2529
Tilmeldt: lør 30. okt 2010 09:09
Geografisk sted: Odense, Fyn
Brugererfaring med Linux:: Lidt øvet

Re: Lektion 2

Indlægaf Måns » søn 6. feb 2011 21:12

kaare skrev:
Kode: Vælg alt
# mount /dev/sdc1  /mnt/sdc1
mount: mount point /mnt/sdc1 does not exist

Betyder det at "/mnt/sdc1 does not exist" .. Dette er fordi at når man mounter et "device" skal det mountes til en mappe og denne mappe skal man selv oprette. Dermed er grunden til at "/mnt/sdc1 does not exist", fordi at du endnu ikke selv har oprettet mappen med fx:
Kode: Vælg alt
sudo mkdir /mnt/sdc1

Efter dette vil det nu være muligt at mounte mount point "sdc1" med
Kode: Vælg alt
# sudo mount /dev/sdc1  /mnt/sdc1


Men igen, for at finde det rigtige mount point anbefaler jeg at du bruger "dmesg" eller "lsusb" lige efter du har indsat usb stikket..

Yezzz :goodp: :cheers: :wink: Super mange tak!! :cheers:
Det her virker (og kan bruges til undervisning!!):
1)
Kode: Vælg alt
# mkdir /mnt/sdc1

2)
Kode: Vælg alt
# mount /dev/sdc1  /mnt/sdc1

3)
Kode: Vælg alt
# cd /mnt/sdc1

4)
Kode: Vælg alt
# ls -l

5)
Kode: Vælg alt
total 4417120
-rwxr-xr-x  1 root root        105 2010-11-16 11:23 boot.msg
drwxr-xr-x  2 root root       4096 2010-11-19 16:12 browserlinux
drwxr-xr-x  7 root root       4096 2010-11-20 15:36 Documents
drwxr-xr-x  2 root root       4096 2010-11-20 15:47 Free PDF to Word Converter
-rwxr-xr-x  1 root root      15484 2010-11-19 20:29 full.menu.lst
-rwxr-xr-x  1 root root  203804672 2010-10-01 22:08 go-oo-3.2-sfs4.sfs
-rwxr-xr-x  1 root root     236923 2010-07-19 22:00 grub.exe
-rwxr-xr-x  1 root root       1036 2010-11-16 11:23 help.msg
-rwxr-xr-x  1 root root    1808508 2010-11-16 10:23 initrd.gz
-rwxr-xr-x  1 root root        540 2009-08-23 21:28 Install_Microsoft_Webcore_Fonts.sh
-rwxr-xr-x  1 root root  729808896 2011-01-19 21:37 jolicloud-1.0.iso
-r-xr-xr-x  1 root root      13671 2010-11-16 11:23 ldlinux.sys
-rwxr-xr-x  1 root root          0 2010-07-13 04:29 liveusb
-rwxr-xr-x  1 root root      19772 2010-11-16 11:23 logo.16
-rwxr-xr-x  1 root root   93118464 2010-09-10 07:51 lupu-510.sfs
-rwxr-xr-x  1 root root  376635392 2010-10-28 13:11 lupu-511.sfs
-rwxr-xr-x  1 root root   33554432 2010-11-18 00:26 lupusave_crypta-mama2.2fs
-rwxr-xr-x  1 root root  536870912 2010-11-16 20:26 lupusave-mama.2fs
-rwxr-xr-x  1 root root 2415919104 2010-11-16 23:49 lupusave-pupstudionov.2fs
drwxr-xr-x  3 root root       4096 2010-11-20 03:44 macpup
-rwxr-xr-x  1 root root   64290816 2010-11-20 03:44 Macpup-511.sfs
-rwxr-xr-x  1 root root       3037 2010-11-20 18:54 menuBack.lst
-rwxr-xr-x  1 root root       3384 2011-01-30 17:52 menu.lst
-rwxr-xr-x  1 root root     645105 2011-01-30 17:40 MultiBootISOs-2.1.5.0.exe
-rwxr-xr-x  1 root root      84779 2010-11-06 01:47 MultiBoot-USB-Creator-Copying.txt
-rwxr-xr-x  1 root root       6660 2010-11-06 02:02 MultiBoot-USB-Creator-Readme.txt
drwxr-xr-x 10 root root       4096 2010-11-20 16:53 PortableApps
drwxr-xr-x  2 root root       4096 2010-11-19 19:27 puppy511
drwxr-xr-x  2 root root       4096 2010-11-20 03:48 puppystudio
drwxr-xr-x  2 root root       4096 2010-11-20 02:41 pyroom_darkeditor
-rwxr-xr-x  1 root root      13276 2010-11-19 18:16 splash.xpm.gz
-rwxr-xr-x  1 root root       1522 2010-11-19 22:19 Svar p? Sp?jsens blog.txt
-rwxr-xr-x  1 root root         39 2009-11-05 17:08 syslinux.cfg
-rwxr-xr-x  1 root root          0 2010-11-16 10:23 USBFLASH
-rwxr-xr-x  1 root root   58109952 2010-11-08 21:03 VirtualBox3.2.8.sfs
-rwxr-xr-x  1 root root    2228800 2010-10-27 22:00 vmlinuz
-rwxr-xr-x  1 root root    5858867 2010-11-28 22:07 win32diskimager-RELEASE-0.2-r23-win32.zip
drwxr-xr-x  2 root root       4096 2010-11-19 15:19 wNOP
#

:cheers: Måns
Quote: "Give a man a tiddler and he might digest it today, show a man how to use TIddlyWiki and he'll be writing his own tiddlers for a lifetime .."
Brugeravatar
Måns
Site Admin
Site Admin
 
Indlæg: 1763
Tilmeldt: tirs 5. jan 2010 18:32
Geografisk sted: Havbro, Aars, Himmerland, Nordjylland, Jylland, Danmark
Brugererfaring med Linux:: Øvet

Re: Lektion 2

Indlægaf kaare » søn 6. feb 2011 21:16

Det var så lidt :) .. Men husk nu at ALT ikke altid bliver mountet på "sdc1" .. derfor kan du jo altid tjekke hvor skidtet skal mountes med "dmesg" eller "lsusb"
----
Kåre Sørensen
kaare
Site Admin
Site Admin
 
Indlæg: 65
Tilmeldt: man 18. maj 2009 19:48
Geografisk sted: Århus C
Brugererfaring med Linux:: Meget øvet

ForegåendeNæste

Tilbage til Linux.deb@ 4 U

Hvem er online

Brugere der læser dette forum: Ingen og 1 gæst

cron