Nyinstalleret Slacko 5.7 kan ikke finde "grldr" [Løst]

En hurtig mini distribution der fx. kan køre kun fra USB-nøgle og i ram.

Redaktør: haines

Nyinstalleret Slacko 5.7 kan ikke finde "grldr" [Løst]

Indlægaf jyrgenf » søn 5. apr 2015 15:55

Jeg booter fra CD-ROM, og installerer så (FULL). sda2 er sat til boot, sda3 er sat til linux-swap.
Når jeg efterfølgende genstarter uden CD-ROM, kommer følgende:

Try (hd0,0): EXT2: No grldr
Try (hd0,1): EXT2: No grldr
Try (hd0,2): non-MS: skip
Try (hd0,3): invalid or null
BIOS: Drive=0x0, H=2, S=18

Hvad gør jeg forkert ?
Mvh
jyrgenf

Amitech Freenote 5011: 1 gb ram, AMD Processor.60 Gb Hdd.
Slacko Puppy 5.7
jyrgenf
 
Indlæg: 5
Tilmeldt: søn 5. apr 2015 14:40
Brugererfaring med Linux:: Helt uøvet

Re: Nyinstalleret Slacko 5.7 kan ikke finde "grldr"

Indlægaf Uffe » man 6. apr 2015 11:38

Hej jyrgenf, og :welcomewav:

Der er andre herinde der er bedre til Puppy end mig, men jeg prøver om jeg kan hjælpe dig. :wink:

Jeg vil prøve at få tid til at hente Slacko 5.7 senere i dag og prøve selv på en testmaskine, men..... umiddelbart vil jeg mene at du skulle ha' sat sda2 til "/ " i stedet for "boot" og så ha' installeret opstartsindlæseren "Grub" på "MBR" partitionen - men det er altså kun et "kvalificeret bud" :mrgreen:

:cheers:
Mvh.
Uffe

Ubuntu minimal m/ Mate desktop 64bit
Asrock N68-GE3 UCC - AMD X4 640 - 4 Gb Kingston ram
OCZ Vertex 4 SSD 60 Gb + 500 Gb WD sATA HD

Ultimate Edition 2.9 64bit
Asrock 2core 1333-2.66G - 2 Gb Kingston ram
750 Gb Samsung WD sATA HD
Plextor DVD-RW - Asus 24" fladskærm

Omega T107, 7" Kina Android tablet
Brugeravatar
Uffe
Site Admin
Site Admin
 
Indlæg: 2105
Tilmeldt: man 20. apr 2009 15:42
Geografisk sted: Hornslet, Syddjurs
Brugererfaring med Linux:: Øvet

Re: Nyinstalleret Slacko 5.7 kan ikke finde "grldr"

Indlægaf jyrgenf » man 6. apr 2015 14:27

Tak for respons :grin:
Hmmmnnnn. "Boot" er blot en mulighed jeg får under "Manage Flags", og der er ikke mulighed for at vælge "/" (eller mener du / = intet flag ?).
Angående MBR, troede jeg at den partition (i mit tilfælde sda2), jeg valte til installationen, ville blive MBR. Er det forkert ?
Mvh
jyrgenf

Amitech Freenote 5011: 1 gb ram, AMD Processor.60 Gb Hdd.
Slacko Puppy 5.7
jyrgenf
 
Indlæg: 5
Tilmeldt: søn 5. apr 2015 14:40
Brugererfaring med Linux:: Helt uøvet

Re: Nyinstalleret Slacko 5.7 kan ikke finde "grldr"

Indlægaf Uffe » man 6. apr 2015 14:57

"/" kan også være defineret som "roden i filsystemet"

MBR tror jeg ikke du uden videre kan flytte. http://da.wikipedia.org/wiki/Master_boot_record

Det er mig bekendt rigtigt at du godt kan boote fra data på en partition som er sat med opstartsflaget "boot", men så skal du kunne vælge din boot-option fra en menu i bios eller med en popup-menu fra en f-tast. (Vist ofte F9, men det plejer at stå ved boot hvilken tast - hvis din bios har den mulighed.)

Håber at det hjælper :smile:

PS. har lige noget kontorarbejde jeg skal ha' overstået, så prøver jeg at hente ISO'en :wave:
Mvh.
Uffe

Ubuntu minimal m/ Mate desktop 64bit
Asrock N68-GE3 UCC - AMD X4 640 - 4 Gb Kingston ram
OCZ Vertex 4 SSD 60 Gb + 500 Gb WD sATA HD

Ultimate Edition 2.9 64bit
Asrock 2core 1333-2.66G - 2 Gb Kingston ram
750 Gb Samsung WD sATA HD
Plextor DVD-RW - Asus 24" fladskærm

Omega T107, 7" Kina Android tablet
Brugeravatar
Uffe
Site Admin
Site Admin
 
Indlæg: 2105
Tilmeldt: man 20. apr 2009 15:42
Geografisk sted: Hornslet, Syddjurs
Brugererfaring med Linux:: Øvet

Re: Nyinstalleret Slacko 5.7 kan ikke finde "grldr"

Indlægaf Uffe » man 6. apr 2015 17:19

Jeg har prøvet at installere (Full) på en ældre testmaskine.

Det første jeg gjorde da jeg havde bootet op fra CD'en var at åbne Gprated og lave mig en partition til formålet. Swap-partition var der i forvejen. Formaterede den til Ext4 (Ext3 eller Ext2 havde også været fint) INGEN opstartsflag :!: (Husk hvad partitionen hedder inden Gparted lukkes :wink: )

Jeg fulgte anvisningerne på skærmen ang. install og endte med at installere "Grub" incl. afhængigheder med pakkeinstallationen. Hertil så godt - jeg kørte
Kode: Vælg alt
update-grub
i terminalen for at den kunne finde det andet OS jeg har på HD'en - men den gik ikke :roll: - den kunne ikke finde en ".list fil i Canonical" skrev den :eek: (mit andet OS er bygget på Ubuntu 12.04 og bruger også Grub 2) :scratch:

Opstart i det andet OS og køre "update-grub" der, så nu virker det - blot hedder Slacko nu "Ukendt Linux" i Grub-menuen :???:

Hvis man har Windows som "det andet OS" har man ikke den mulighed :thumbdown: Der ligger også en anden opstartsindlæser i Slacko, nemlig Grub4dos - men når jeg søger på din fejlmelding ser det ud til at størstedelen af dem der er rendt ind i samme problem som dig, har brugt Grub4dos, så......................

................ Håber nogle andre har et bud på løsningen :crossfingers:

:cheers:
Mvh.
Uffe

Ubuntu minimal m/ Mate desktop 64bit
Asrock N68-GE3 UCC - AMD X4 640 - 4 Gb Kingston ram
OCZ Vertex 4 SSD 60 Gb + 500 Gb WD sATA HD

Ultimate Edition 2.9 64bit
Asrock 2core 1333-2.66G - 2 Gb Kingston ram
750 Gb Samsung WD sATA HD
Plextor DVD-RW - Asus 24" fladskærm

Omega T107, 7" Kina Android tablet
Brugeravatar
Uffe
Site Admin
Site Admin
 
Indlæg: 2105
Tilmeldt: man 20. apr 2009 15:42
Geografisk sted: Hornslet, Syddjurs
Brugererfaring med Linux:: Øvet

Re: Nyinstalleret Slacko 5.7 kan ikke finde "grldr"

Indlægaf jyrgenf » man 6. apr 2015 20:46

Uffe skrev:Hvis man har Windows som "det andet OS" har man ikke den mulighed :thumbdown: Der ligger også en anden opstartsindlæser i Slacko, nemlig Grub4dos - men når jeg søger på din fejlmelding ser det ud til at størstedelen af dem der er rendt ind i samme problem som dig, har brugt Grub4dos, så......................
:cheers:


:goodp:
Grub4Dos var lige hvad jeg havde benyttet, og der lå fejlen også. Jeg kørte den igen, og valgte noget med "enkelt side". Jeg bemærkede at "menu.lst" nu lagde sig i en anden mappe, og DET VIRKER !

Uffe skrev:................ Håber nogle andre har et bud på løsningen :crossfingers:
:cheers:


Der er skam ikke brug for andres hjælp. DIN hjælp har været super. Mange tak :clap:
Mvh
jyrgenf

Amitech Freenote 5011: 1 gb ram, AMD Processor.60 Gb Hdd.
Slacko Puppy 5.7
jyrgenf
 
Indlæg: 5
Tilmeldt: søn 5. apr 2015 14:40
Brugererfaring med Linux:: Helt uøvet

Re: Nyinstalleret Slacko 5.7 kan ikke finde "grldr"

Indlægaf Uffe » man 6. apr 2015 20:51

............ Kun glad for at kunne hjælpe :grin: :grin:

(jeg tillader mig lige at tilføje [Løst] til toppen af tråden)

:cheers:
Mvh.
Uffe

Ubuntu minimal m/ Mate desktop 64bit
Asrock N68-GE3 UCC - AMD X4 640 - 4 Gb Kingston ram
OCZ Vertex 4 SSD 60 Gb + 500 Gb WD sATA HD

Ultimate Edition 2.9 64bit
Asrock 2core 1333-2.66G - 2 Gb Kingston ram
750 Gb Samsung WD sATA HD
Plextor DVD-RW - Asus 24" fladskærm

Omega T107, 7" Kina Android tablet
Brugeravatar
Uffe
Site Admin
Site Admin
 
Indlæg: 2105
Tilmeldt: man 20. apr 2009 15:42
Geografisk sted: Hornslet, Syddjurs
Brugererfaring med Linux:: Øvet


Tilbage til Puppy-linux

Hvem er online

Brugere der læser dette forum: Ingen og 2 gæster

cron