TWsOS TW-OS revival

En hurtig mini distribution der fx. kan køre kun fra USB-nøgle og i ram.

Redaktør: haines

Re: TWsOS TW-OS revival

Indlægaf mjjzf » tors 7. mar 2013 11:35

Nydeligt!
Brugeravatar
mjjzf
Site Admin
Site Admin
 
Indlæg: 508
Tilmeldt: man 14. mar 2011 01:32
Geografisk sted: Valby, Danmark
Brugererfaring med Linux:: Meget øvet

Re: TWsOS TW-OS revival

Indlægaf Birthe » søn 14. apr 2013 13:07

Hej Måns
Jeg har brugt din seneste danske sprogpakke på den oprindelige TWsOS og undrer mig lidt. Ved nedlukning kommer en dialogboks og spørger om jeg vil oversætte initrd, anbefaler der siges ja, hvorefter der kommer en fejlmeddelse om, at det alligevel ikke kan lade sig gøre, noget med en anden grub!

Jeg har lagt TWsOS på usb med unetbootin.
Mvh. Birthe

Lenovo T500 Intel Core 2 Duo 2.53 GHz, 2 GB DDR3, 160GB 7200rpm, ATI Mobility Radeon HD 3650, Mint 17.2 Mate
Lenovo X100e 2gb ram, AMD Athlon Neo MV-40 / 1.6 GHz, ATI Mobility Radeon HD 3200, zorin 6.4 core
Acer Aspire One zg5, Intel Atom N270, 1.6 GHz, integreret grafik, 1gb ram, 160 gb hd. (Mint 17.3 Mate)
Brugeravatar
Birthe
Site Admin
Site Admin
 
Indlæg: 2485
Tilmeldt: lør 30. okt 2010 09:09
Geografisk sted: Odense, Fyn
Brugererfaring med Linux:: Lidt øvet

Re: TWsOS TW-OS revival

Indlægaf Måns » søn 14. apr 2013 14:32

Hej Birthe
Birthe skrev: der kommer en fejlmeddelse om, at det alligevel ikke kan lade sig gøre, noget med en anden grub!
Jeg har lagt TWsOS på usb med unetbootin.

Kør grub4dos på usb'en. Slet uid linie(r) fra de genererede menu.lst filer (også advanced). Lad grub4dos installere grub på usb.
Prøv igen.
:red-cheers: :red-cheers: :red-cheers:
Mvh Måns
Quote: "Give a man a tiddler and he might digest it today, show a man how to use TIddlyWiki and he'll be writing his own tiddlers for a lifetime .."
Brugeravatar
Måns
Site Admin
Site Admin
 
Indlæg: 1761
Tilmeldt: tirs 5. jan 2010 18:32
Geografisk sted: Havbro, Aars, Himmerland, Nordjylland, Jylland, Danmark
Brugererfaring med Linux:: Øvet

Re: TWsOS TW-OS revival

Indlægaf Birthe » tirs 16. apr 2013 19:50

Hej Måns
Måns skrev:Kør grub4dos på usb'en. Slet uid linie(r) fra de genererede menu.lst filer (også advanced). Lad grub4dos installere grub på usb.
Prøv igen.

Jeg forsøgte og fik boot'et Windows XP fra usb'en. Puppy derimod nægter grub at finde, siger bootmanageren forventer en anden signatur for en harddisk. Det ER ikke en harddisk. Grub ligger på en usb, og det gør puppy naturligvis også.
Jeg kan se, at menu.lst er blevet noget mere omfattende, end sidst jeg forsøgte mig med det.
I andet forsøg, blev puppy tilsyneladende fundet, hvorefter grub ledte videre på harddisk og der var jo ikke nogen puppy.
Adskillige forsøg og læsning om grub4dos senere.
Det er grub4dos værktøjet i Precise Puppy 5.5, jeg har prøvet med.
Jeg er kommet i tanker om, hvorfor jeg bruger Unetbootin :lol: :lol: :lol:

Redigeret: Det dæmrede for mig, at jeg for at bruge grub4dos værktøjet i puppy, kørte puppy fra en ANDEN usb stick. Derfor skrev grub4dos sdg1 i menu.lst, mens det ved reboot med kun den ene usb stick skulle være sdb1. Denne gang lykkedes boot. Men det gik så langsomt, at jeg faktisk var ved at slukke computeren og opgive.
Der må da være et eller andet galt?
:red-cheers: :red-cheers:
Mvh. Birthe

Lenovo T500 Intel Core 2 Duo 2.53 GHz, 2 GB DDR3, 160GB 7200rpm, ATI Mobility Radeon HD 3650, Mint 17.2 Mate
Lenovo X100e 2gb ram, AMD Athlon Neo MV-40 / 1.6 GHz, ATI Mobility Radeon HD 3200, zorin 6.4 core
Acer Aspire One zg5, Intel Atom N270, 1.6 GHz, integreret grafik, 1gb ram, 160 gb hd. (Mint 17.3 Mate)
Brugeravatar
Birthe
Site Admin
Site Admin
 
Indlæg: 2485
Tilmeldt: lør 30. okt 2010 09:09
Geografisk sted: Odense, Fyn
Brugererfaring med Linux:: Lidt øvet

Re: TWsOS TW-OS revival

Indlægaf Måns » tirs 16. apr 2013 22:17

Hej Birthe
Birthe skrev:Der må da være et eller andet galt?

Jep :cool:

Grub4dos finder kun Puppy installationer, der ligger i en mappe på roddrevet (f.eks. en usb pen).

Unetbootin lægger filerne direkte på roden - derfor er det nødvendigt at oprette en mappe til puppyfilerne - og søge igen med grub4dos...

:red-cheers: :red-cheers: :red-cheers:
Mvh Måns
Quote: "Give a man a tiddler and he might digest it today, show a man how to use TIddlyWiki and he'll be writing his own tiddlers for a lifetime .."
Brugeravatar
Måns
Site Admin
Site Admin
 
Indlæg: 1761
Tilmeldt: tirs 5. jan 2010 18:32
Geografisk sted: Havbro, Aars, Himmerland, Nordjylland, Jylland, Danmark
Brugererfaring med Linux:: Øvet

Re: TWsOS TW-OS revival

Indlægaf Birthe » ons 17. apr 2013 00:13

Hej Måns
Måns skrev:Grub4dos finder kun Puppy installationer, der ligger i en mappe på roddrevet (f.eks. en usb pen).

Puppyfilerne lå i en mappe på usb pen. Der blev som sagt søgt på drevet adskillige gange med grub4dos og jeg søgte kun på det drev.
Det lykkedes jo også tilsidst at boot'e, men så langsomt, at jeg aldrig ville orke at bruge puppy.
Jeg tog ikke tid på det, men normalt ville puppy være nået til desktoppen og et par pets være blevet installeret på den tid, det tog. :scratch:
Mvh. Birthe

Lenovo T500 Intel Core 2 Duo 2.53 GHz, 2 GB DDR3, 160GB 7200rpm, ATI Mobility Radeon HD 3650, Mint 17.2 Mate
Lenovo X100e 2gb ram, AMD Athlon Neo MV-40 / 1.6 GHz, ATI Mobility Radeon HD 3200, zorin 6.4 core
Acer Aspire One zg5, Intel Atom N270, 1.6 GHz, integreret grafik, 1gb ram, 160 gb hd. (Mint 17.3 Mate)
Brugeravatar
Birthe
Site Admin
Site Admin
 
Indlæg: 2485
Tilmeldt: lør 30. okt 2010 09:09
Geografisk sted: Odense, Fyn
Brugererfaring med Linux:: Lidt øvet

Re: TWsOS TW-OS revival

Indlægaf Måns » ons 17. apr 2013 01:11

Hej Birthe
Birthe skrev:H
Puppyfilerne lå i en mappe på usb pen. Der blev som sagt søgt på drevet adskillige gange med grub4dos og jeg søgte kun på det drev.:

:scratch: :scratch: :scratch: :scratch: hmmmm

Prøv at skrive din egen menu.lst entry:
Kode: Vælg alt
title Puppy navn
  kernel /mappenavn/vmlinuz   psubdir=mappenavn pmedia=usbflash pfix=fsck
  initrd /mappenavn/initrd.gz


Der må ikke være mellemrum i mappenavnet - og der må ikke være mere end 1 niveau/lag (dvs. kun 1 mappe ned - ikke 2..). :crossfingers: :crossfingers: :crossfingers:

Meget, meget mystisk :scratch: :scratch:
:red-cheers: :red-cheers: :red-cheers:

Mvh Måns
Quote: "Give a man a tiddler and he might digest it today, show a man how to use TIddlyWiki and he'll be writing his own tiddlers for a lifetime .."
Brugeravatar
Måns
Site Admin
Site Admin
 
Indlæg: 1761
Tilmeldt: tirs 5. jan 2010 18:32
Geografisk sted: Havbro, Aars, Himmerland, Nordjylland, Jylland, Danmark
Brugererfaring med Linux:: Øvet

Re: TWsOS TW-OS revival

Indlægaf Birthe » ons 17. apr 2013 10:45

Hej Måns
Det bliver mere mystisk. Jeg har jo brugt grub4dos tidligere, dog ikke fra usb. Jeg skrev egen menu.lst i forsøget, der trods alt endte med en boot. Det langsomme forsøg.

Kan man have flere puppies på samme usb? hvis det lykkes. I så fald er jeg nødt til at få styr på det....der ligger nemlig på trods af alt en splinterny 64 gb usb og kigger lokkende - lige her ved siden af. Derudover en skov af små usb med hver deres puppy, deraf mindst 2 custom builds.

Skal alt det øvrige i menu.lst slettes og hvad med menu-advanced.lst?...please....... :crossfingers:
Jeg har undret mig meget over de lange og omfattende lst-filer.

grub4dos blev sat til at undersøge usb drev, grub blev installeret til usb, Puppy blev fundet på usb, men det gjorde Windows på harddisk også, og der står om boot af windows, ligesom advanced lst også gerne vil finde grub2 på harddisken. Jeg tænker, det må være alt det, der tager tid, Der ledes fra kælder til kvist. Hvor meget af det, kan man smide ud?

Først står der:
Try hd0.0 Fat 32,
så fortsættes og stoppes og i lang tid ved
[Linux-bzImage, serup=3x3e00 size=0x29825]
Og eeeeeeeeeeeeeeeeendelig bootes og alt kører normalt.

Jeg prøvede min seneste remaster og denne gang har jeg vist fået det ønskede med - undtagen Firefox extensions. Har du et tip til det? Antagelig er det fordi, jeg flytter firefox opsætning og symlinker.
Mvh. Birthe

Lenovo T500 Intel Core 2 Duo 2.53 GHz, 2 GB DDR3, 160GB 7200rpm, ATI Mobility Radeon HD 3650, Mint 17.2 Mate
Lenovo X100e 2gb ram, AMD Athlon Neo MV-40 / 1.6 GHz, ATI Mobility Radeon HD 3200, zorin 6.4 core
Acer Aspire One zg5, Intel Atom N270, 1.6 GHz, integreret grafik, 1gb ram, 160 gb hd. (Mint 17.3 Mate)
Brugeravatar
Birthe
Site Admin
Site Admin
 
Indlæg: 2485
Tilmeldt: lør 30. okt 2010 09:09
Geografisk sted: Odense, Fyn
Brugererfaring med Linux:: Lidt øvet

Re: TWsOS TW-OS revival

Indlægaf Måns » ons 17. apr 2013 17:20

Hej Birthe
Birthe skrev:Kan man have flere puppies på samme usb? hvis det lykkes. I så fald er jeg nødt til at få styr på det....der ligger nemlig på trods af alt en splinterny 64 gb usb og kigger lokkende - lige her ved siden af. .

Jep - Een mappe pr. puplet. Grub4dos finder dem - og savefiles gemmes automatisk til de rigtige mapper.
Tillykke med din nye MONSTERUSB :thumbup: :thumbup: :clap: :clap: :clap:

Jeg er lige blevet færdig med en oversættelse af TWsOS til dansk.
Denne udgave har en opgraderet udgave af OwnCloud : den sidste nye OwnCloud 5.04.

Den kan hentes her: TWsOSv5_da.2.iso (ca. 653 Mb)
Md5sum:
Kode: Vælg alt
ef399cd442ee662f468c847c6df52e88


Ps. Så skulle den være der :crossfingers: :crossfingers: :crossfingers:
:red-cheers: :red-cheers: :red-cheers:
Mvh Måns
Quote: "Give a man a tiddler and he might digest it today, show a man how to use TIddlyWiki and he'll be writing his own tiddlers for a lifetime .."
Brugeravatar
Måns
Site Admin
Site Admin
 
Indlæg: 1761
Tilmeldt: tirs 5. jan 2010 18:32
Geografisk sted: Havbro, Aars, Himmerland, Nordjylland, Jylland, Danmark
Brugererfaring med Linux:: Øvet

Re: TWsOS TW-OS revival

Indlægaf Birthe » ons 17. apr 2013 17:47

Hej Måns
Måns skrev:Jep - Een mappe pr. puplet. Grub4dos finder dem - og savefiles gemmes automatisk til de rigtige mapper.
Tillykke med din nye MONSTERUSB :thumbup: :thumbup: :clap: :clap: :clap:

Der blev gemt savefil til rigtig mappe, den duede bare ikke. Det gentog sig et par gange. Jeg mistede tålmodigheden og prøvede en remaster og det gik udmærket - altså minus en detalje, jeg glemte.

Måns skrev:Tillykke med din nye MONSTERUSB :thumbup: :thumbup: :clap: :clap: :clap:

Tak. jeg har ikke prøvet den endnu. grub4dos booter langsomt selv fra lille usb stick.
Birthe skrev:[Linux-bzImage, serup=3x3e00 size=0x29825]

Det er ikke inspirerende at kigge på. Det er meget hurtigere at skifte usb. Ærgeligt for jeg kunne godt tænke mig en form for orden i alle de mange puppies.
Måns skrev:Jeg er lige blevet færdig med en oversættelse af TWsOS på dansk.
Denne udgave har en opgraderet udgave af OwnCloud : den sidste nye OwnCloud 5.04.

Spændende. Fik du de programmer, der drillede dig til at virke? Hvis jeg ikke finder en løsning på grub4dos, så er TWsOS da en værdig kandidat til den monsterusb.
Mvh. Birthe

Lenovo T500 Intel Core 2 Duo 2.53 GHz, 2 GB DDR3, 160GB 7200rpm, ATI Mobility Radeon HD 3650, Mint 17.2 Mate
Lenovo X100e 2gb ram, AMD Athlon Neo MV-40 / 1.6 GHz, ATI Mobility Radeon HD 3200, zorin 6.4 core
Acer Aspire One zg5, Intel Atom N270, 1.6 GHz, integreret grafik, 1gb ram, 160 gb hd. (Mint 17.3 Mate)
Brugeravatar
Birthe
Site Admin
Site Admin
 
Indlæg: 2485
Tilmeldt: lør 30. okt 2010 09:09
Geografisk sted: Odense, Fyn
Brugererfaring med Linux:: Lidt øvet

ForegåendeNæste

Tilbage til Puppy-linux

Hvem er online

Brugere der læser dette forum: Ingen og 1 gæst

cron